DE- Commerzbank increased failure rates and higher response times

Incident Report for Qwist availability

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 16:13 CEST

Identified

We have received the following information from Commerzbank:

"Since October 22, 2025, at 09:44 AM, Commerzbank’s API has been affected by an incident. They are observing increased failure rates and longer response times. The Commerzbank team is working on resolving the issue and will provide updates once it has been fixed."

As a result, you may experience issues when connecting to Commerzbank accounts via Qwist.
We will continue to monitor the situation and share updates as soon as new information becomes available.

Thank you for your understanding.

Your Qwist Support Team
Posted Oct 22, 2025 - 12:07 CEST
This incident affected: Connectivity Availability - DE (Commerzbank).