Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 04:00 CET
Scheduled
due to maintenance work, there will be a outage of 90 min of the interface on the 12th of November 2025 between 04:00AM and 05:30AM. Online banking and the banking app will be affected by this downtime
Posted Nov 05, 2025 - 18:15 CET
This scheduled maintenance affected: Connectivity Availability - DE (Commerzbank).