DE/AT/ES - Account SwitchKit, Portfolio SwitchKit, PAD - Unplanned service interruption

Incident Report for Qwist availability

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 15:00 CEST

Investigating

Dear Qwist customer,

we have identified an unplanned service interruption of our Account SwitchKit, Portfolio SwitchKit and Payments Accounts Directive Service.

We are already working on a resolution and will update you as soon as we have further information.

If you have any questions in the meantime, please contact us via partnersupport@qwist.com

Best regards,
Qwist team
Posted Apr 01, 2026 - 14:04 CEST
This incident affected: Portfolio SwitchKit (Portfolio SwitchKit User Interface, Portfolio SwitchKit Backoffice), Payments Accounts Directive Service (Payments Accounts Directive Service User Interface, Payments Accounts Directive Service Backoffice), and Account SwitchKit (Account SwitchKit v3.0, Account SwitchKit Backoffice).