Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 04, 2025 - 22:00 CET
Scheduled
Due to maintenance work, there will be a short-term outage of 5 min of the interface on the 4th of November 2025 between 10:00PM and 11:00PM. All our services will be affected of this downtime.
Posted Oct 30, 2025 - 13:14 CET
This scheduled maintenance affected: Connectivity Availability - DE (Commerzbank).